Friday, June 06, 2014

My Internet was blocked by bad DNS

My internet connection was working fine just the day before. And this morning when I powered up my PC, no connection could be established. I didn’t know I have a bad DNS problem and was wondering what could be wrong.

I checked my other PC in the LAN network including my mobile phone and they all could connect online. Looking at the error message, it said it was blocked by my browser. So the first thing that came to mind was my PC firewall. The quick way to test it was switching off the firewall. Unfortunately, no connection could be established.

The next step was to try disabling the anti-virus. Even that didn’t work.

Trying to pinpoint the error, I tried running other browsers. Perhaps my current Google Chrome browser was getting cranky. Unfortunately, Mozilla Firefox and Opera browser didn’t work either.

Finally, after giving the error message a second look, I realized the error message came from Open DNS. In my bid to overcome the blocking of certain sites by the Malaysian government, I have switched from TM net DNS primary/secondary servers to those of overseas.

A quick change on my Local Area Connection properties TCP/IPv4 Primary and Secondary DNS server address to another one, voila! My connection was established. This time I switched over to Google’s DNS server.

So most likely the Open DNS gateway servers were down, or they too started implement some kind of blocking procedure. Fortunately I still have some other alternate choices to try.

Well that solved my problem, though it took me about 2 hours to figure it out! What a time waster!

No comments: